Python 2.3 - Is the release still on schedule?

Jimmy Retzlaff jimmy at
Tue Jun 24 02:19:58 CEST 2003

John Ochiltree (joch at wrote:

> ...I want to use the 2.3 Set functionality. Has anyone an
> idea of suitable strategies to deal with this temporarily...

I've been using the sets and heapq modules for a while now in 2.2. I
simply grabbed copies of and from CVS and dropped them
in my Python Path. I don't remember having to change anything in the
code to get it to work with 2.2. Just look for here:

After a brief look at the change log, it looks like started
using itertools in version 1.38, so you may have to get version 1.37 or
older if you want it to run unchanged in 2.2. I have no idea if there
have been significant API changes since then.


More information about the Python-list mailing list