from python1.5.2 to python2.2.2

Aahz aahz at pythoncraft.com
Wed Nov 5 16:41:04 CET 2003


In article <3ef166ac.3608218 at news.marelli.it>,
Alberto Mantovani <alberto.mantovaniNOSPAM at bologna.marelli.it> wrote:
>
>I have a lot of scripts written in python1.5.2 that I want to bring in
>python2.2.2.  Someone could give me some informations about the sintax
>difference between this 2 version?

If you want to upgrade your scripts to use new features, you've got a lot
of work ahead.  If you simply want to run them unaltered in 2.2.2, go
ahead and try it!  One of Python's primary goals is maintaining backward
compatibility; you should have very little difficulty.

Note: I'd recommend using 2.2.3 if possible; there are a few more bugs
fixed in it.
-- 
Aahz (aahz at pythoncraft.com)           <*>         http://www.pythoncraft.com/

"It is easier to optimize correct code than to correct optimized code."
--Bill Harlan




More information about the Python-list mailing list