building python extensions with .net sdk compiler?

Anthony Baxter anthony at interlink.com.au
Mon Nov 17 13:47:06 CET 2003


I'm trying to build a binary of fastaudio (the wrapper for the PortAudio
library, from http://www.freenet.org.nz/python/pyPortAudio/) for Python 2.3.
There's a lot of FAQs and the like out there that give some simple directions,
involving fetching the .net sdk from MSDN and distutils "should work" - 
however, when I follow them and try to do the setup.py build step, I get
a message:
  error: Python was built with version 6 of Visual Studio, and extensions need 
  to be built with the same version of the compiler, but it isn't installed.

Argh. All I want is a simple way to say 'give me a binary object that I can 
drop into my site-packages directory'. Is there a way, or am I screwed?

Anthony

--
Anthony Baxter     <anthony at interlink.com.au>
It's never too late to have a happy childhood.






More information about the Python-list mailing list