Memory exception with Tkinter root.quit

Bengt Richter bokr at
Tue Nov 18 04:19:16 CET 2003

On 17 Nov 2003 18:08:01 -0800, janeaustine50 at (Jane Austine) wrote:

>>Jane Austine wrote:
>>>>>from Tkinter import *
>>> And when I press the "Quit" button the mainloop exits. After that,
>>> I finish the python shell, a memory exception occurs.
>>> This is Windows XP machine with Python 2.3.
>> Not much of a help, but I've tried it here: no problems... (python
>> 2.3.2, win xp).  Can it be a Python 2.3.0 issue that has been fixed in
>> 2.3.1 or 2.3.2 ?
>> --Irmen
>I tried it with 2.3.2, but it doesn't work either.
>The crash message is:
>python.exe -- application program error
>the command from "0x77f7e22a" referenced the memory at "0x00000028".
>The memory couldn't be "read".

Another data point:

For me it ran seemingly ok in an NT4 console window, but with idle it acted weird,
and I couldn't capture the session screen (oops, maybe Ctl-C is no good for that there)
Anyway, the Quit button changed to depressed look, and then was stuck visible but not responding.
I had to kill it with task manager. Then idle printed a -----restart----- line.

Bengt Richter

More information about the Python-list mailing list