Problem with tkinter

rolf peter ropebu at web.de
Wed Nov 12 12:58:38 CET 2003


Hello Friends,

i installed the new Python 2.3 tarball but have a little (or big) problem.

When testing turtle.py i get the following message. 
I am using Linux SUSE 8.2, Tk ist installed as version 8.4

./configure, make and make install work fine ....

Python 2.3 (#2, Nov 11 2003, 17:40:46)
[GCC 3.3 20030226 (prerelease) (SuSE Linux)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>>

but: 

ropebu at z3pc47:/usr/local/lib/python2.3/lib-tk> python turtle.py
Traceback (most recent call last):
  File "turtle.py", line 4, in ?
    import Tkinter
  File "/usr/local/lib/python2.3/lib-tk/Tkinter.py", line 38, in ?
    import _tkinter # If this fails your Python may not be configured for Tk
ImportError: No module named _tkinter

So the questions is: how to configure python to use Tk.

Greeting from Karlsruhe




More information about the Python-list mailing list