idle2.3 character encoding

wiretooth wire.tooth at ntlworld.com
Mon Nov 3 10:37:47 CET 2003


Hi all,
I have a problem with idle2.3 instalation of 2.2.3 under the
fedora-severn linux dist. It looks like a local / encoding thing. I'm
pretty new to linux / python so no advice is to obviuous.

On idle2.3 startup the version banner looks like it is a single byte
print of a wide string. For example the first few chars in the shell
window are:

P\x00y\x00\t

characters I type at the prompt are rendered corectly;
>\x00>\x00x = "foobar"
>\x00>\x00print x

but the execution of the print statement yeilds

f\x00o\x00o\x00

There are five chars printed. ie len(x). It's as though on printing
output the shell window is treating wide /utf-8 ? chars as ascii.

Hacking print encoding into libidle/IOBinding.py just after it picks
the encoding results in UTF-8

A final aside is that I'm not convinced my install is sane. After
running into this I tried to rpm -e the 2.3.2 packages. This failed
claiming they weren't installed. So I tried rpm -ivh on them and this
also failed claiming they were installed.

help & rescue much needed :)

-W




More information about the Python-list mailing list