2.3.2 complilatiion problem

Ling Jiang baljiangusa at yahoo.com
Tue Nov 11 05:10:30 CET 2003


Thanks for the advices. 

It worked, with 5.6 being altered to reflect release number of the OS,
which is 5.9 in my case.

Thanks

Ling Jiang

Nigel Rowe <rho at big_NOSPAM_pond.com> wrote in message news:<vpCrb.4525$aT.3345 at news-server.bigpond.net.au>...
> navigating wrote:
> 
> > The attached (gcc.err) came out of the compilation on solaris 9 on an
> > intel platform using gcc. I've also attached the config.log. Please
> > advise.
> > 
> > Regards.
> > 
> > Ling Jiang
> 
> First bit of advice, do *NOT* post 11,000 line (320k) log files!!!
> 
> 2nd. When I get to the 'gcc.err' part of your post (after working around the
> tendency for my newreader to freeze when presented with 11000 line posts.
> Got the hint?) I see the error is "previous declaration of 'va_list'"  
> 
> 2 Mins with google leads to
> https://sourceforge.net/tracker/?func=detail&atid=105470&aid=690317&group_id=5470
> so you might try zenzen's suggestion.
> 
> --8<--
> Hacking configure so it looks like the following
> allows python to  build:
>   case $ac_sys_system/$ac_sys_release in
>     # On OpenBSD, select(2) is not available if
> _XOPEN_SOURCE is defined,
>     # even though select is a POSIX function. Reported by J.
> Ribbens.
>     SunOS/5.6 | OpenBSD/2.* | OpenBSD/3.[012])
>       define_xopen_source=no;;
>   esac
> --8<--
> 
> Beyond this I cannot help as I have no access to any solaris box




More information about the Python-list mailing list