Tkinter "Expected boolean value"

Jeff Epler jepler at unpythonic.net
Sat Nov 29 16:00:36 CET 2003


You'd do better with tk8.3 than 8.4.  There were some incompatible
changes in Tk 8.4's "bind" command that cause Python problems.  I'm not
sure in what version of Python this problem is fixed.

As for your 'expected boolean value' problem, there's not enough
information for me to guess the cause.  It's not something I've heard of
before.  If you want help, your best bet would be to post a small
program that is runnable and demonstrates the problem.

Jeff





More information about the Python-list mailing list