newbie script

ataraxia2500 messageboardfan1 at yahoo.com
Thu Sep 25 17:32:12 CEST 2003


Peter Otten wrote:

> ataraxia2500 wrote:
> 
>> I get that weird error when I tried to run the little loop, this is what
>> it says:
>> 
>> sys:1: DeprecationWarning: Non-ASCII character '\xa0' in file myloop.py
>> on line 3, but no encoding declared; see http://www.python.org/peps
>> pep-0263.html for details
>>   File "myloop", line 3
>>     os.system('/home/joe/src/myprog/myprog')
>>     ^
>> SyntaxError: invalid syntax
>> 
>> does it mean anything to you?
> 
> 
> The whitespace before os.system() consists of '\xa0' characters, no idea
> why.
> 
> However, I have noticed that when I copy and paste from KNode 7.2 using
> Strg+C/Strg+V instead of the middle mouse button, all '\xa0' are magically
> converted back to old '\x20' space characters.
> 
> Peter
ok thanx that was the problem, I use knode from CVS and when I did a Ctrl+C
it asked me what encoding I wanted, how neat! but I had no idea which one
to chose, after two failure I decided to type it by myself and it worked :)




More information about the Python-list mailing list