[ANN] pylint-0.2

Peter Milliken peterm at resmed.com.au
Mon Sep 29 22:07:25 CEST 2003

Hi Peter,

No, I caught all of the dependencies that are required (common libraries and
optik - I think that is all that is required). I installed both of them
before attempting to run pylint and still received that error. Perhaps the
install is order dependent i.e. I installed pylint, then the "common
libraries" then the optik package.

Does Pylint work for you?


"Peter Hansen" <peter at engcorp.com> wrote in message
news:3F782D20.5BB43A1F at engcorp.com...
> Peter Milliken wrote:
> >
> > I get the same error.
> [snip]
> > (I have a personal hangup with people who
> > write good, useful packages and then don't bother documenting them -
life is
> > just too short to read somebody else'e code to get around this
> > :-) I get frustrated however when I think there is something that I
could be
> > taking advantage of but something as simple as the lack of 0.5hr of
> > documentation stops me :-( ).
> Maybe RTFM would help.  See
http://www.logilab.org/projects/pylint/documentation and
> note the "dependancies" (sic) line which states "Pylint requires the
> logilab-common(version >= 0.2.1) and the optik packages."
> If you download the "Common libraries" from the links provided on that
> I suspect it will work better.
> Unfortunately, by posting the direct link to the download I suspect
> led people astray by implying that a single download might be enough to
> this work.
> -Peter

More information about the Python-list mailing list