Image manipulation library under a GPL-compatible license?

Fredrik Lundh fredrik at pythonware.com
Sun Aug 8 01:31:06 CEST 2004


"Leif K-Brooks" wrote:

> I need to do some simple image editing (pretty much just scaling) in a
> GPLed program. Unfortunatly, both of the Python libraries for image
> editing that I found (gdmodule and PIL) are under the GPL-incompatible
> original BSD license. Is there another library under a friendlier library?

sorry, but you don't have the slightest idea what you're talking
about.  PIL uses the original Python license, about which FSF
has the following to say:

    This is a free software license and is compatible
    with the GNU GPL.

    http://www.gnu.org/philosophy/license-list.html

and before you spread more license FUD, maybe you should
learn why the *original* BSD license is not considered to be
GNU-compatible:

    http://www.gnu.org/philosophy/bsd.html

</F>






More information about the Python-list mailing list