TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'

Martin Koekenberg martin at koekenberg.net
Fri Aug 20 10:28:22 CEST 2004


Hello,

Ik get the following error when I install a new Python software
package such as Zope or PIL.

This is what I get whem I 'make'  Zope :

running build_ext
Traceback (most recent call last):
  File "/usr/local/zope/Zope-2.7.2-0/setup.py", line 1091, in ?
    distclass=ZopeDistribution,
  File "/usr/local/lib/python2.3/distutils/core.py", line 149, in
setup
    dist.run_commands()
  File "/usr/local/lib/python2.3/distutils/dist.py", line 907, in
run_commands
    self.run_command(cmd)
  File "/usr/local/lib/python2.3/distutils/dist.py", line 927, in
run_command
    cmd_obj.run()
  File "/usr/local/lib/python2.3/distutils/command/build.py", line
107, in run
    self.run_command(cmd_name)
  File "/usr/local/lib/python2.3/distutils/cmd.py", line 333, in
run_command
    self.distribution.run_command(command)
  File "/usr/local/lib/python2.3/distutils/dist.py", line 927, in
run_command
    cmd_obj.run()
  File "/usr/local/lib/python2.3/distutils/command/build_ext.py", line
244, in run
    customize_compiler(self.compiler)
  File "/usr/local/lib/python2.3/distutils/sysconfig.py", line 159, in
customize_compiler
    cpp = cc + " -E"           # not always
TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'
make: *** [build] Error 1                


./configure has finisched withoud problems.

System : Fedora Core 2
Python 2.3.3


What is wrong here ?

Greetings,

Martin Koekenberg



More information about the Python-list mailing list