Rather than decorators, how about sections?

Christopher T King squirrel at WPI.EDU
Wed Aug 11 21:56:39 CEST 2004


On Wed, 11 Aug 2004, Paul Morrow wrote:

> Fine, instead of Foo (the name of the class), use the word klass.  It's 
> a popular name for the first parameter of a class method.

My code uses 'cls' for this purpose.  I'm sure others stick with 'self'.  
No matter what you pick, it will break something.

To quote the Zen of Python: "Explicit is better than implicit."




More information about the Python-list mailing list