pre-PEP generic objects
carribeiro at gmail.com
Fri Dec 3 14:39:57 CET 2004
On Fri, 03 Dec 2004 07:41:59 -0500, Steve Holden <steve at holdenweb.com> wrote:
> Next question: bunch is a cute name, but not very suggestive of purpose.
> Who can think of a better one?
"Better"is highly subjective in this context. There are several alternatives:
I use "DataRecord" in my own code, because it's readable and makes it
clear that it's not a full fledged class, but a data-only structure.
Given my Pascal roots, I'm also fond of "Record". But given that many
people actually loathe Pascal (probably for reasons deeply rooted in a
bad academic experience :-), that may be a big "turn off".
Consultoria em Projetos
mail: carribeiro at gmail.com
mail: carribeiro at yahoo.com
More information about the Python-list