trouble building python2.4

Matthew Thorley ruach at chpc.utah.edu
Wed Dec 22 18:14:50 CET 2004


Greetings, I just downloaded the python2.4 source from python.org and 
built it the usual way, i.e. ./configure && make. What I don't 
understand is that the resulting binary, when run, prints this line 
Python 2.3.4 (#1, Nov 15 2004, 10:29:48) at the top of its banner. 
Further more, the poplib modules complains when I try to call the 
poplib.POP3_SSL class, saying that the module has no such class, though 
the online docs say it does.

I read the README and I didn't see anything about having to pass options 
to configure to get it to build version 2.4. I appears to me that the 
tarball I downloaded wasn't really python2.4, even though it was 
'official' and named Python-2.4.tgz.

Can anyone please tell me what might of happened, or if they have had a 
similar experience?

Thanks
-Matthew



More information about the Python-list mailing list