Renaming __getattribute__ (PEP?)

Henry 'Pi' James henrypijames at
Mon Dec 13 05:32:10 CET 2004

I'm pretty sure this must not be a new idea, but it seems no one else
has voiced their agitation about the name "__getattribute__" so far.
Its closeness to "__getattr__" is only one thing that irritates tons of
people, as is apparent through the endless repeating question about the
difference between the two, and through the fact that every lecture on
"new classes" in Python feels contrained to explain that difference.
More importantly, the name "__getattribute__" does not reflect what
this built-in methode is precisely for, namely "to implement attribute
accesses for instances of the class" [1]. Thus, as I've been wondering
the whole time, why is it not called "__accessattr__" instead? That
would be much clearer and distinctly different to "__getattr__", not to
mention being in sync with the "attr"-instead-of-"attribute"

This whole issue seems so obvious and trivial to me that I've in fact
expected it to be resolved by itself - respectively, by the Python
language developer community which generally pays so much attention to
details. Now, after it has failed to happen till now, I feel the strong
urge to speak it out.

It this qualified PEP stuff?


[1] Python Reference Manual (current release), section

More information about the Python-list mailing list