VC++ 6.0 and 2.4

"Martin v. Löwis" martin at v.loewis.de
Fri Dec 10 09:35:19 CET 2004


Jive wrote:
> Theoretically, if I messed around with the 2.4 project until I got it to
> build under MS VC++ 6.0, would the python.exe play correctly with version
> 2.4 .pyd extensions?

My initial answer was no, as 2.4 .pyd extensions are build with VC 7.1,
and that uses a different CRT. However, as David Fraser points out,
"2.4 .pyd extensions" doesn't really say much what compiler has been
used, so if you use VC6 to build the extensions, it will work fine.

Also, I'm not sure what "mess around with the 2.4 project" means. Are
you talking about the project and solution files in PCbuild? Don't
mess with them, use PC/VC6 instead.

Regards,
Martin



More information about the Python-list mailing list