thread/queue bug

phil phillip.watts at anvilcom.com
Fri Dec 10 21:17:02 CET 2004


 > 4. The fact that you have a .pyc file instead of a .py
 > file very likely has *nothing* to do with any threading
 > problem you are facing, so I suggest you get past that mental
 > block and look elsewhere.

Well, I tried to make it clear that the ONLY difference between
working and not working was the pnetx.pyc when imported did not
work when
#!/usr/bin/python
# pnet.py, exists only to import pnetx.py
import pnetx.py

Otherwise the program has worked fine for months.
I don't think its a mental block, its the ONLY difference.
It freezes on the following statement:
mq = Queue(0)
and I haven't a clue why.  All the other threads continue to run.

 > 5. Sorry I can't be more help.  You don't give anyone much
 > to go on.  All that stuff about "Queue(0)" and "listenq"
 > is pretty much meaningless to us, you know...

You know, I get this all the time on language support groups.
All of my Linux support groups, if they don't understand, say
why and ask for elaboration.  I tried to explain what was going on,
without incuding the source.  I have about 200 man hours in the source
and I bet it would take longer to understand it.
If my explanation was insufficient, I'm sorry.

ALSO, you did not respond to my email, so I didn't know how to reply.
There is nothing on the archives page which gives me a clue as to
how to respond.

SO, if there is ZERO chance there is some sort of inadvertent lock
occuring in saved byte code, I just kludge around and move on.
Maybe 2.4

Thanks.





More information about the Python-list mailing list