The python2.4 IDLE can't be lanuched.

Abe Mathews 59bassman at gmail.com
Mon Dec 6 17:49:17 CET 2004


Don't know if this would help or not, but on my Linux 2.3 IDLE, I get
the following warning on startup:


    ****************************************************************
    Personal firewall software may warn about the connection IDLE
    makes to its subprocess using this computer's internal loopback
    interface.  This connection is not visible on any external
    interface and no data is sent to or received from the Internet.
    ****************************************************************

I'm not running SP 2 on any machines, so I can't test it for you, but
it may be that the personal firewall being activated on SP 2 is
blocking IDLE from starting up.  You might try turning that off and
seeing if that helps.  IIRC, part of SP 2 was port disabling.

I have to install SP 2 on a machine later today.  If I get the chance
I'll test it  and see if I can make the same failure occur.

Abe Mathews


On Mon, 06 Dec 2004 11:28:56 -0500, Brian Beck <exogen at gmail.com> wrote:
> Brian Beck wrote:
> > I have the exact same problem.  The IDLE window just never opens, and
> > checking the process list shows that is was never even launched.  So I
> > can't make much use of Python 2.4 since I use IDLE as my IDE...
> 
> I forgot to note that I am also using Windows XP SP2 and this happens on
> two completely different machines of mine.
> 
> 
> 
> --
> Brian Beck
> Adventurer  of the First Order
> --
> http://mail.python.org/mailman/listinfo/python-list
>



More information about the Python-list mailing list