PyKDE/PyQT/SIP

Sam stardif10 at hotmail.com
Sun Feb 15 03:13:55 CET 2004


Hey people,

I am trying to install these modules to play around with KDE panel 
applets, but I am beginning to think it's too much trouble to be worth it.

I've installed PyQT (as well as the PyQT-devel rpm, which is apparently 
needed if I install PyQT from an rpm), PyKDE and the sip module. When I 
run the importTest.py script that comes with PyKDE, I get this:

-------------------------------------
Testing PyKDE module imports

dcop
/usr/lib/python2.3/site-packages/dcop.py:22: RuntimeWarning: Python C 
API version mismatch for module libsip: This Python has API version 
1012, module libsip has version 1011.
   import libsip
kdecore
kdesu
kdefx
kdeui
Traceback (most recent call last):
   File "importTest.py", line 7, in ?
     exec ("import " + mod)
   File "<string>", line 1, in ?
   File "/usr/lib/python2.3/site-packages/kdeui.py", line 67, in ?
     import libkdeuic
ImportError: libpython2.3.so.1.0: cannot open shared object file: No 
such file or directory
---------------------------------

If anyone could give me an easy solution to the problem (or any 
solution, but easy would be preferable ;) that would be fantastic.

Thanks,
Sam.




More information about the Python-list mailing list