a curious IDLE Error

EP EP at zomething.com
Thu Jan 22 06:50:01 CET 2004


I'm not sure this error is of note, but it was curious to me (a puzzle).

Windows 2000, Python 2.3, using IDLE file editor and shell

I had a small script which imported string and worked fine until I added a 
std. input line:
	raw_input("some prompt")

It opened IDLE and died with error:
	'tuple' object not callable

I closed the IDLE shell, re-ran the module, which opened a new IDLE shell 
and repeated the same error.  Did this many times.

I opened a separate instance of Python (IDLE shell) and tried the raw_input 
function: it ran fine.
I ran my module at the Windows command prompt, and it ran fine.

I opened a new Python shell from the instance of IDLE editor where my 
module was open and tried the raw_input():

 >>> someFile=raw_input("enter:  ")
Traceback (most recent call last):
   File "<pyshell#36>", line 1, in ?
     someFile=raw_input("enter:  ")
TypeError: 'tuple' object is not callable


Can anyone point me in the right direction?


Eric

Apologies for the lack of proper analysis, I am all ears.





More information about the Python-list mailing list