Python 2.3.3 compilation problem

DoubleM mmoum at woh.rr.com
Sat Jan 3 01:21:55 CET 2004


Zdenda wrote:

> Hi, i have RH9 and i need python 2.3. I executed tgz file and typed
> ./configue. Then i type make. It is without problem. When I type make
> install ... ...
> ...
> Compiling /usr/local/lib/python2.3/xml/sax/handler.py ...
> Compiling /usr/local/lib/python2.3/xml/sax/saxutils.py ...
> Compiling /usr/local/lib/python2.3/xml/sax/xmlreader.py ...
> Compiling /usr/local/lib/python2.3/xmllib.py ...
> Compiling /usr/local/lib/python2.3/xmlrpclib.py ...
> Compiling /usr/local/lib/python2.3/zipfile.py ...
> make: *** [libinstall] Error 1
> 
> Have somebody any idea where is error?
> Thanks
I had the same problem on Mandrake.  There seem to be some minor syntax
incompatibilities in zipfile.py, and others.  Try make -i install, and all
should be fine.

Mike



More information about the Python-list mailing list