some tests fail (was: Re: RELEASED Python 2.4, alpha 1)

Irmen de Jong irmen at -NOSPAM-REMOVETHIS-xs4all.nl
Mon Jul 12 23:19:12 CEST 2004


Michael Hudson wrote:
> Irmen de Jong <irmen at -nospam-remove-this-xs4all.nl> writes:
> 
> 
>>Anthony Baxter wrote:
>>
>>>On behalf of the Python development team and the Python community, I'm
>>>happy to announce the first alpha of Python 2.4.
>>
>>Great stuff.
>>
>>One thing ; the format test isn't working:
>>(Mandrake 10, gcc 3.3.2)
>>
>>$ make test
>>
>>...
>>test_format
>>test test_format produced unexpected output:
>>**********************************************************************
>>*** line 2 of actual output doesn't appear in expected output after line 1:
>>+ u'%f' % (1.0,) == u'1,000000' != '1.000000'
>>**********************************************************************
> 
> [snippety]
> 
> This has the foul, rotten stench of something involving locales.  What
> is the default locale on your system?  There's probably some test that
> runs before test_format on your system that is messing things up.

My default locale is NL_nl, which does indeed contain ',' for the decimal symbol.
And I have to agree with your feeling that an earlier test messes something up,
because when I run the test_format test by itself, it runs fine without error.

However, when I switch locales to en_US, the test still fails! (same error).


> Binary chop?

Sorry, what do you mean by that?

--Irmen



More information about the Python-list mailing list