a bug in urllib?

Haim Ashkenazi haim at babysnakes.org
Sat Jul 3 20:54:13 CEST 2004


Hi

I'm writing a script that uses urllib on win98. until now I used python
2.3.x (x < 4) and it worked ok. I re-installed windows and installed
python 2.3.4 and now I get an error when trying to open a url "no host
given":

Python 2.3.4 (#53, May 25 2004, 21:17:02) [MSC v.1200 32 bit (Intel)] on win32

Type "copyright", "credits" or "license()" for more information.



    ****************************************************************

    Personal firewall software may warn about the connection IDLE

    makes to its subprocess using this computer's internal loopback

    interface.  This connection is not visible on any external

    interface and no data is sent to or received from the Internet.

    ****************************************************************

    

IDLE 1.0.3      

>>> import urllib

>>> f = urllib.URLopener()

>>> x = f.open('http://www.python.org')



Traceback (most recent call last):

  File "<pyshell#2>", line 1, in -toplevel-

    x = f.open('http://www.python.org')

  File "C:\PYTHON23\Lib\urllib.py", line 181, in open

    return getattr(self, name)(url)

  File "C:\PYTHON23\Lib\urllib.py", line 281, in open_http

    if not host: raise IOError, ('http error', 'no host given')

IOError: [Errno http error] no host given

>>> 

--------------------------------------------

I don't think it's a network error because I can browse to this site
without a problem. does anyone have any idea? is it a bug? can anyone tell
me where I can download an earlier version (not activestate, it's not
running well on my win98)?

Bye
-- 
Haim






More information about the Python-list mailing list