Is this just for readability to the developer? python

David Stockwell winexpert at
Wed Jun 2 15:37:25 CEST 2004

Thanks for the help.

It makes it easier that its automated....


>From: "Miki Tebeka" <miki.tebeka at>
>To: David Stockwell <winexpert at>
>CC: python-list at
>Subject: Re: Is this just for readability to the developer? python
>Date: Wed, 2 Jun 2004 16:25:19 +0200
>Hello David,
> > initModule( "$Revision: 3.1 $".split(" ")[1] )
> > ...
> > In this example, it looks like only the '3.1' is actually passed to the
> > function.  Which leads me to speculate that the rest of it is just there 
> > make it easier for the developer when looking at source code to see what
> > version of the module is being used.
> >
> > The only thing I think i notice is its also passing a list of one 
> >
> > Is this a typical way to do this in python?
>The $Revision: ...$ is expaned by CVS/Subversion/... when you check in a
>file (These are called "RCS keywords", see
>This way the revision is actually maintined by the source control system.
>Miki Tebeka <miki.tebeka at>
>The only difference between children and adults is the price of the toys.

MSN 9 Dial-up Internet Access fights spam and pop-ups – now 3 months FREE!

More information about the Python-list mailing list