SocketServer Problem

Ergin Aytac ergin_aytac at yahoo.de
Sat Jun 26 01:42:47 CEST 2004


The origin script is a gateway for syncronizing news on usenet servers. 
As I can see there are a lot of people who use this script for public 
usenet groups. I saw some using it for news.php.net, news.mozilla.org 
without being a part of this domains. Besides I have the access rights 
for news.chello.at which recognizes me over the domain name I'm using. 
Without any access rights I should also get access to a few public 
groups. The friend who tried this server without any errors doesn't work 
for chello and his box is not a part of chello.

Something is strange here...

Can I bind a socket to an address that is public and has no access 
limits? (like public usenet servers as news.php.net or news.mozilla.org)



Irmen de Jong schrieb:
> Ergin Aytac wrote:
> 
>> nntp_hostname = 'news.chello.at'
>> nntp_port = 119
> 
> 
> 
> I very much doubt it that the computer you are trying to run
> the program on, is actually called "news.chello.at"....
> 
>> socket.error: (10049, "Can't assign requested address")
> 
> 
> You cannot bind a socket on an address that is not 'yours' ...
> 
>> The script above worked without any error message on a box of friend.
> 
> 
> Now that is weird. Unless your friend works for Chello and his
> box is "news.chello.at"...
> 
> --Irmen



More information about the Python-list mailing list