Is this just for readability to the developer? python

Miki Tebeka miki.tebeka at
Wed Jun 2 16:25:19 CEST 2004

Hello David,

> initModule( "$Revision: 3.1 $".split(" ")[1] )
> ...
> In this example, it looks like only the '3.1' is actually passed to the 
> function.  Which leads me to speculate that the rest of it is just there to 
> make it easier for the developer when looking at source code to see what 
> version of the module is being used.
> The only thing I think i notice is its also passing a list of one element?
> Is this a typical way to do this in python?
The $Revision: ...$ is expaned by CVS/Subversion/... when you check in a
file (These are called "RCS keywords", see
This way the revision is actually maintined by the source control system.

Miki Tebeka <miki.tebeka at>
The only difference between children and adults is the price of the toys.

More information about the Python-list mailing list