Idle Won't Start - Solution

Kamilche klachemin at home.com
Wed Jun 2 07:57:11 CEST 2004


I had a problem starting IDLE today, and managed to fix it. I'm
posting this for future reference.

IDLE worked fine, up until I got bold and tried to set a key binding.
When attempting to set the 'dedent region' keystring to shift-tab, the
shell printed an error. Past that point, IDLE wouldn't start up. I
deinstalled and reinstalled Python various times using various
options, cleaned out the registry, and scoured the Internet. I had the
latest versions of TCL and TKinter, and didn't have that DLL mismatch
some were talking about. Attempting to run the idle.py script directly
inside of python, resulted in a TCLError "bad event type or keysym
'tab'" message.

Finally, I discovered that IDLE saves some configuration files in the
Documents and Settings folder, under your user id! Delete the
'config-keys.cfg' and 'config-main.cfg' files in the 'C:\Documents and
Settings\<UserName>\.idlerc' folder, and it will start working again.

Yeesh! If it can't handle setting keyboard shortcuts, it shouldn't
SAVE a corrupt file after failing!

--Kamilche



More information about the Python-list mailing list