KinterBasDB problems in Linux

fowlertrainer at anonym.hu fowlertrainer at anonym.hu
Mon Mar 1 16:40:54 CET 2004


Hello !

Very interesting thing:
When I copy this script to another dir, it is working, but in this
directory is not working.
Only different is to this dir is used by an symlink.

The python is not working good with symlinked dirs ???

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>


So: in Debian Sarge, some interesting thing happened.

When I start python with:
/usr/bin/python
it is starting the py2.3

When I write this:
import kinterbasdb<crlf>
the py2.3 is not say this:
"import _kinterbasdb as _k"
"ImportError: No module named _kinterbasdb"
only do the import.
So it is working.

BUT !

If I write this line to a script:
#!/usr/bin/python
import kinterbasdb
this error I get:
"import _kinterbasdb as _k"
"ImportError: No module named _kinterbasdb"

Why ?
What I do wrong ??????

Anybody know it ?


Monday, March 1, 2004, 12:15:04 PM, you wrote:

UG> I don't have any proplems with cross-platform issues.
UG> Working on Win2000 + suse linux 8.2, 9.0 and FB 1.5,
UG> kinterbasdb from http://sourceforge.net/projects/kinterbasdb/

I try with apt-get install "kidb", and do same things.

UG> Try this version!

UG> Uwe


UG> fowlertrainer at anonym.hu wrote:

>> Hello !
>> 
>> I have a problem.
>> I create my projects in Windows, and I write a database synchronizing
>> utility for copy a gdb changes to another gdb. Some of these products
>> is need to run in linux.
>> 
>> I'm very tired, because I download (apt-get install
>> python2.3-kinterbasedb) the module, what working good in Windows, but
>> in linux I get this message when I try to start my script:
>> 
>> bha:/kepes# ./syncmdb2teldb.py
>> Traceback (most recent call last):
>>   File "./syncmdb2teldb.py", line 2, in ?
>>     import kinterbasdb
>>   File "/home/fixshare/kepes/kinterbasdb/__init__.py", line 41, in ?
>>     import _kinterbasdb as _k
>> ImportError: No module named _kinterbasdb
>> bha:/kepes#
>> 
>> 
>> The test file is:
>> File: syncmdb2teldb.py  Col 0              321 bytes            100%
>> #!/usr/bin/python
>> import kinterbasdb
>> 
>> import sys
>> # Base datas
>> 
>> srcdb=kinterbasdb.connect(dsn='192.168.1.17:/mpanni/bha/database/teldata.gdb',us
>> er='sysdba',password='m',charset="win1250")
>> desdb=kinterbasdb.connect(dsn='192.168.1.17:/mpanni/bha/database/mpanni.gdb',use
>> r='sysdba',password='m',charset="win1250")
>> print "ok"
>> 
>> 1Help   2UnWrap 3Quit   4Hex    5Line   6RxSrch 7Search 8Raw    9Unform 10Quit
>> 
>> In the package dir:
>> 
>> bha:/usr/lib/python2.3/site-packages/kinterbasdb# ls -l
>> total 152
>> -rw-r--r--    1 root     root        29691 Jul 19  2002 __init__.py
>> -rw-r--r--    1 root     root        32036 Feb 27 17:44 __init__.pyc
>> -rw-r--r--    1 root     root        32036 Feb 27 17:44 __init__.pyo
>> -rw-r--r--    1 root     root        56072 Sep 28 16:32 _kinterbasdb.so
>> bha:/usr/lib/python2.3/site-packages/kinterbasdb#
>> 
>> 
>> What I do wrong, or what is it ????
>> (The Zope with Kinterbasdb is working good in this linux, so no
>> connection problem...)
>> 
>> thanx for every help !
>> 





-- 
Best regards,
 fowlertrainer                            mailto:fowlertrainer at anonym.hu








More information about the Python-list mailing list