Python bytecode compatibility between interpreter versions

Michael Hudson mwh at python.net
Fri Mar 19 13:38:07 CET 2004


Jon Perez <jbperez808 at yahoo.com> writes:

> Can one run a 1.5 .pyc file with the 2.x version
> interpreters and vice versa?
> 
> How about running a 2.x .pyc using a 2.y interpreter?

Both are hopeless, in practice.

Cheers,
mwh

-- 
  ZAPHOD:  OK, so ten out of ten for style, but minus several million
           for good thinking, eh?
                    -- The Hitch-Hikers Guide to the Galaxy, Episode 2



More information about the Python-list mailing list