Python 2.4 and Visual C++ Express

Steve Menard menard.nospam.steve at gmail.nospamisaid.com
Wed Nov 24 22:50:54 CET 2004


Jive wrote:
> "Steve Menard" <menard.nospam.steve at gmail.nospamisaid.com> wrote in message
> news:30ji62F31ppn0U1 at uni-berlin.de...
> 
>>Jive wrote:
>>
>>>Are you saying that Python 2.4 will not compile under MS VC++ 6.0?
> 
> That's
> 
>>>horrifying.  Say it isn't so!!!  I have just ported Python to an
> 
> embedded
> 
>>>system using VC++ 6.0.  It will always be compiled using 6.0, for two
>>>reasons: 1) I cannot afford the manhours for changing compilers, and 2)
> 
> Bill
> 
>>>Gates has enough money already, alright?  I would hate to think that I
> 
> am
> 
>>>now stuck at Python 2.3 for eternity.
>>>
>>
>>That is not what I am saying. The "what's new in Python" claims python
>>2.4 will
>>compile with both versions 6 and 7.1 of Microsoft's compiler.
>>
>>However, the  standard download, that most users will have, will be
>>compiled using the 7.1. And so any binary packages to be installed on a
>>2.4 dist will also have to be compiled with 7.1.
>>
>>
>>Steve
>>
> 
> 
> Do you mean if I install 2.4, I will have to find VC++ 7.1 versions of all
> the extensions
> I may be using?  If so, that's still borderline horrible, but I guess
> Microsoft is the culprit. Annow
> for something completely the same.
> 
> Will 7.1 extensions work with a Python.exe compiled under 6.0?
> 
> In any case, I think it would be a Good Thing if the Pythonistas provided a
> download of 2.4
> compiled under VC++ 6.0, in addition to the 7.1 one.
> 
> I don't suppose it will do any good to rant about Microsoft.  I believe it's
> been done.
> 
> 
> 

We can rant all we want, but let's be realistic : Version 6.0 is 
ancient! It is the version I was using at work almost 8 years ago!

Would you hold that python on Linux should compile with an 8 year old 
version of GCC? At one point, a break must happen ...

At least there seems a way to use MS's free 7.1 toolkit to compile, 
something that was'nt possible with version 6.

Lastly, about existing extensions. Extension are python version 
specific. An extension compiled for python 2.3 will NOT work with python 
2.4, no matter what. My guess is that soon after the release of Python 
2.4, maintainers of existing packages will distribute them in 2.3 and 
2.4 forms. My hope is that distuil will be intelligent enough to chose 
the right compiler when both will be present. I am one of those 
maintainers, and I do not want to have to jump through hoops to get my 
modules to compile ...


Steve



More information about the Python-list mailing list