RadioBox in wxPython

Cliff Wells clifford.wells at comcast.net
Wed Nov 3 05:16:56 CET 2004


On Tue, 2004-11-02 at 16:42 -0200, Jorge Godoy wrote:
> Cliff Wells <clifford.wells at comcast.net> writes:
> 
> > On Wed, 2004-10-27 at 03:34 +0000, StvB wrote:
> >> Do I have to go to 2.4 in order to start using wx.Control, versus wxControl 
> >> ?
> >
> > Yes.  But frankly, if you are going to upgrade, why not go to 2.5?  In
> > 2.4 the wx namespace is a hack.  In 2.5 it's the real thing.  Plus there
> > are plenty of other enhancements.
> 
> One reason is that the website states that 2.4 is the latest stable
> series, while 2.5 is the latest development series.

Right, but I've been using wx for several years and I can assure you
that the development branch is where you want to be.  It is no less
stable and tends to be far better functionality-wise.  The only possible
instability is in the API and frankly you'll only notice if you move
from 2.4 to to 2.5.

> WRT the hack, the wxwidgets people abandoned the changes there...  

But not the wxPython people, which is what we care about here ;)

-- 
Cliff Wells <clifford.wells at comcast.net>




More information about the Python-list mailing list