distutils and Debian

Sam Holden sholden at flexal.cs.usyd.edu.au
Thu Nov 11 01:27:18 CET 2004


On Wed, 10 Nov 2004 19:08:09 -0500, Colin J. Williams <cjw at sympatico.ca> wrote:
> The distutils download page has:
> --------------------------------------------------------
> Current stable release
>
> The current stable release is Distutils 1.0.2; you can download it as:
>
>      * Distutils-1.0.2.tar.gz (source distribution) (233k)
>      * Distutils-1.0.2.zip (source distribution) (274k)
>      * Distutils-1.0.2.win32.exe (Windows installer) (187k)
>
> If you are running Python version 1.6 or later, you do not need to 
> download the Distutils: they're included with Python. However, if you 
> have a Distutils more recent than your Python, you might want to install 
> it: see the Distutils README.txt file. Version 1.0.2 is identical to the 
> version included in Python 2.1.
> ---------------------------------------------------------
>
> With Debian, it seems that distutils is not included for
> Python 2.2 or 2.3.
>
> Should this be reported as a Debian bug?

No.

It's in the python2.x-dev packages.

Debian often split large things up into smaller packages, distutils
isn't needed by the basic debian user who only installs debian
packages after all. 

"apt-cache search distutils" finds it easily enough for those who do
want it.

-- 
Sam Holden



More information about the Python-list mailing list