Python 2.3.4 under AT&T MP RAS SVR4: ld: Symbol referencing errors.

Alexander Landgraf alexander.landgraf at
Wed Oct 20 23:56:48 CEST 2004

Hi group,

I am not sure if this is the correct place for my question.
If not, please tell me.

I tried to compile Python 2.3.4 under AT&T MP RAS SVR4:
$./configure --prefix=${HOME} --with-threads=no
but make fails because each invocation of ld causes errors like:

running build
running build_ext
building 'struct' extension
cc -DNDEBUG -O -OPT:Olimit=0 -I. -I/home/q904958/src/python2_3_  
4/./Include -I/home/q904958/src/python2_3_4/Include -
I/home/q904958/src/python2_3_4 -c /home/q904958/src/python2_3_
4/Modules/structmodule.c -o build/temp.dwh1-4.0-3446-2.3/structmodule.o
(cc:) Unknown optimization designation: -OPT:Olimit=0. Opt level 0 
NCR High Performance C Compiler R3.0c 
(c) Copyright 1994-98, NCR Corporation
(c) Copyright 1987-98, MetaWare Incorporated
ld build/temp.dwh1-4.0-3446-2.3/structmodule.o -L/usr/local/lib -o 
Undefined			first referenced
 symbol  			    in file
strftime           build/temp.dwh1-4.0-3446-2.3/structmodule.o
__wcstok_ptr_      build/temp.dwh1-4.0-3446-2.3/structmodule.o
PyLong_FromUnsignedLong build/temp.dwh1-4.0-3446-2.3/structmodule.o
PyInt_Type         build/temp.dwh1-4.0-3446-2.3/structmodule.o
PyLong_Type        build/temp.dwh1-4.0-3446-2.3/structmodule.o
PyTuple_Type       build/temp.dwh1-4.0-3446-2.3/structmodule.o
UX:ld: ERROR: build/lib.dwh1-4.0-3446-2.3/ fatal error: Symbol 
referencing errors. No output written to build/lib.dwh1-4.0-3446-

My questions are:
1) Does that mean ld is unable to locate libraries?
   (Which libraries? strftime() is declared in time.h but
    I guess PyInt_Type is Python specific)
2) What is the correct way to specify library locations?
   (I tried ./configure --with-libs=-L/usr/lib but 
    ld arguments did not change)

Thank you for any hints.


More information about the Python-list mailing list