test_tcl and Python 2.4a3

E. Daniel yhdanid at yahoo.com
Mon Oct 4 01:18:25 CEST 2004

After I ran the regrtest suite on Python 2.4a3 several times to make sure, I noticed that when test_tcl's turn comes up and it is run that instead of 2 threads appearing in Wintop.exe (a process viewer for Windows 98) for Python that five threads then appear and these threads (extra or otherwise) continue even after test_tcl is finished and test_tempfile and those after it are picked up and run. This behavior does not seem to happen in Python 2.3.4, where test_tcl is not found in the regrtest suite BTW.
Trying to narrow the problem down, I ran test_tcl on its own, and sure enough Wintop showed three more threads for Python 2.4a3, which itself seems to hang, even after the Tkinter window the test shows is closed.
But coming back to running test_tcl within the regrtest suite, and most often than not when the regrtest reaches test_threaded_import I get the message that the test crashed because it could not create threads. Does all this seem like there is a bug somewhere, or is my Python/Tcl/Tkinter copy bad?
Thank you

Do you Yahoo!?
New and Improved Yahoo! Mail - Send 10MB messages!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20041003/4a80e31e/attachment.html>

More information about the Python-list mailing list