Help - my Tkinter is broken

Francesco Bochicchio bockman at virgilio.it
Sun Oct 3 11:51:17 CEST 2004


On Sat, 02 Oct 2004 17:39:57 +0000, Mike Moum wrote:

> Hi,
> 
> I'm running Mepix Linux, which is a Debian based distribution. 
> Python-2.3.4 is installed in /usr/lib.  When I try to import Tkinter 
> into Python, I get the following error message:
> ImportError: /usr/lib/python2.3/lib-dynload/_tkinter.so: undefined 
> symbol: PyFPE_jbuf
> I've tried the following fixes:
> 1) Recompile Python from scratch.  No good.
> 2) Delete _tkinter.so from /usr/lib/Python2.3/lib-dynload, then 
> recompile.  However, when I did that there was no _tkinter.so rebuilt in 
> /usr/lib/Python2.3/lib-dynload.  I have sub-directories for tcl-8.4 and 
> tk-8.4 under /usr/lib.
> 3) Thinking that the compilation process is looking for tk and tcl under 
> /usr/local/lib, I created symlinks there to /usr/lib/tcl-8.4 and 
> /usr/lib/tk-8.4, and then repeated step 2.  Still no _tkinter.so.
> 

Last time I compiled python on Linux (it was the 1.6 ) in order to include
statically Tkinter (or other modules), you needed to tweak with one file
in the Setup sub-directory of the source tree. Given the sore state of my
brain RAM, I can't be more precise than that.

BTW I have Debian Testing and Tkinter works for python 2.3.4. Did you try
simply download and install official python and python-tk debian packages?
(assumed that Mepix is compatible enough with Debian). 

HTH

Ciao
--------
FB



More information about the Python-list mailing list