What about an EXPLICIT naming scheme for built-ins?

Marco Aschwanden PPNTWIMBXFFC at spammotel.com
Fri Sep 3 15:43:33 CEST 2004


On Fri, 3 Sep 2004 10:33:29 -0300, Carlos Ribeiro <carribeiro at gmail.com> 
wrote:

> I propose a slightly different approach. First, proposing a generic
> naming scheme for built-ins is an ambitious goal, to say the least.

Agreed.

> 1) sorted() and reversed() should return sequences.
>
> 2) add two new builtins, called respectively xsorted() and
> xreversed(), as the iterator versions of sorted() and reversed(). This
> way we keep the existing naming convention for range() and xrange().

That is a good idea and does not introduce a new naming scheme. Good.

Cheers,
Marco




More information about the Python-list mailing list