plone site in separate database - MountFolder

krzychu at bmpg.pl krzychu at bmpg.pl
Wed Aug 31 16:20:49 CEST 2005


Hallo,
I have an existing plone site called "info", I've added some scripts to
it.
I would like to have that plone site into a separate ZODB
database(separate
.fs file).
There is a MountFolder product (1.2 - the latest release), by mean of
this
you can create MountFolder which data is stored in separate ZODB
database.
See manual
http://cvs.sourceforge.net/viewcvs.py/ingeniweb/MountFolder/README.txt?rev=1.6
(I don't use ZEO section).
Creating this MountFolder works fine. There is my registry in
etc/zope.conf
file of my zope instance:
           <zodb_db infi2>
                <filestorage>
                      path $INSTANCE/var/infi2.fs
                </filestorage>
                 mount-point /infi2
                   container-class
Products.MountFolder.MountFolder.MountFolder
          </zodb_db>

But I can't import my plone site or even create brand new plone site
from
Add menu in the MountFolder.
When I try to import my plone site I get the following error:
        Error Type: AttributeError
        Error Value: portal_types
When I try to add brand new plone site from Add menu (Plone Site
position) I
get the following error:
        Error Type: AttributeError
        Error Value: portal_url

I've noticed that some standard actions in MountFolder don't work as
well.
For instance when I try to paste Image object into MountFolder I get
error
too:
        Error Type: AttributeError
        Error Value: portal_url


How can I solve this problem?
Do you have any ideas how to put existing plone site into separate
database?

Regards
Crissssss




More information about the Python-list mailing list