while c = f.read(1)

Greg McIntyre greg at puyo.cjb.net
Mon Aug 22 11:26:44 CEST 2005

The 2nd option has real potential for me. Although the total amount of
code is greater, it factors out some complexity away from the actual
job, so that code is not obscured by unnecessary compexity. IMHO that's
great practice.

I like it! Thank you! The assurance that the code was clear was good
too - that is also what I need to hear (decisively dismissing the quest
for something shorter and punchier will make me happy as much as
succeeding in it).

I'll read all the other suggestions first though.

More information about the Python-list mailing list