gtkmozembed in fedora core 3

Jonas Geiregat yux at sdf-eu.org
Tue Aug 23 17:22:00 CEST 2005


Martin DeMello wrote:
> Could someone help me get gtkmozembed working under fc3? The only
> available rpms need gnome-python2 >= 2.9 and fc3 ships with 2.6. I can't
> find any fc3 rpms to upgrade gnome-python2 and I can't quite figure out
> what I'd need to compile just to install gtkmozembed and the python
> bindings (I need to deploy this at work, so I'm trying to make the
> minimal possible change to a stock fc3 install). Upgrading to fc4 is
> sadly not an option :-/
> 
> martin
> 

If you can't find any rpm's there aren't any available.
You need to compile mozilla with (I think) support for gtkmozembed but I 
guess that's done by default when you compile mozilla with 
ac_add_options --enable-default-toolkit=gtk2 in your mozconfig file.
Check /usr/lib/mozilla for libgtkembedmoz.so if it's not there you'll 
have to rebuild your mozilla/firefox rpm , again I think, these are just 
some random tips ..
Good luck!



More information about the Python-list mailing list