Managing import statements

Kent Johnson kent at kentsjohnson.com
Sun Dec 11 06:04:18 CET 2005


Jean-Paul Calderone wrote:
> On Sat, 10 Dec 2005 13:40:12 -0500, Kent Johnson <kent at kentsjohnson.com> 
>> Do any of these tools (PyLint, PyChecker, pyflakes) work with Jython? To
>> do so they would have to work with Python 2.1, primarily...
> 
> Pyflakes will *check* Python 2.1, though you will have to run pyflakes 
> itself using Python 2.3 or newer.

In that case will it freak when it sees imports that aren't valid in 
CPython, like

import java
from javax.swing import JLabel

or is it doing syntactic analysis without trying to load the referenced 
modules?

Hmm, maybe I should just try it...

Thanks,
Kent



More information about the Python-list mailing list