Building Python 2.4 on machines that do not support dynamic loading

"Martin v. Löwis" martin at v.loewis.de
Sun Dec 4 20:50:30 CET 2005


Robert McLay wrote:
> I have been trying to build python on Cray X1.  As far as I can
> tell it does not support dynamic loading.  So the question is:
> 
>    How to build 2.4 without dynamic loading?

Make sure HAVE_DYNAMIC_LOADING isn't defined; configure should detect
this automatically.

> That is: can I build 2.4 where all the extensions are archived in
> libpython2.4.a as a static library?

Certainly: Edit Modules/Setup to your needs.

Regards,
Martin



More information about the Python-list mailing list