urllib2 problem/bug: Request.add_header does() nothing?

kelio at yandex.ru kelio at yandex.ru
Mon Jul 25 18:35:07 CEST 2005


I have a simple cgi-script on a server that prints all key-value pairs
from a request. And it really works when i use a browser and type smth
like http://server/cgi-bin/test?name=mike&johny=dummy. But when I use
the following script, nothing is printed (like i type
http://server/cgi-bin/test request in the browser).

What is wrong about it? It's hard to believe there's a bug nobody's
noticed for such a long time (I've tried Python 2.1.3 and 2.4.1 on
Windows, and 2.2.2 on Linux).

I've also tried to make a request using urllib (without 2) sending
pairs as data in a POST request - and it also worked.

Thanks for help!

elio.

#!/usr/bin/python

import urllib2

request = urllib2.Request(r"http://server/cgi-bin/test")
request.add_header("product", "SohoCore")
request.add_header("version", "1.1")
request.add_header("build", "1251")

reply = urllib2.urlopen(request).readlines()

for i in reply:
	print i




More information about the Python-list mailing list