[path-PEP] Path inherits from basestring again

Peter Hansen peter at engcorp.com
Mon Jul 25 17:22:10 CEST 2005

Reinhold Birkenfeld wrote:
> Current change:
> * Add base() method for converting to str/unicode.

Would basestring() be a better name?  Partly because that seems to be 
exactly what it's doing, but more because there are (or used to be?) 
other things in Path that used the word "base", such as "basename".

-1 on that specific name if it could be easily confused with "basename" 
types of things.


More information about the Python-list mailing list