Problem on python 2.3.x was: [ANN] Snakelets 1.41 and Frog 1.6

Irmen de Jong irmen.NOSPAM at xs4all.nl
Sun Jun 5 00:58:46 CEST 2005


...darn, some users have reported that a strange problem
occurs when running Snakelets 1.41 on Python 2.3.x
(Python 2.4 is fine!)

It seems that there is a bug in older versions of
inspect.getmodule() and that bug causes Snakelets to stop
working correctly on Python 2.3.x

If you experience this bug (you can see it in the server.log
"arg is not a module, class, method, function, traceback, frame,
or code object") please upgrade to Python 2.4.1 if possible.

In the meantime I will try to make a workaround so that Snakelets
will work again on older Python versions.

Sorry for the trouble,

--Irmen.



More information about the Python-list mailing list