Pre-PEP: Dictionary accumulator methods
michele.simionato at gmail.com
Sat Mar 19 06:03:52 CET 2005
+1 for inc instead of count.
appendlist seems a bit too specific (I do not use dictionaries of lists
The problem with setdefault is the name, not the functionality.
get_or_set would be a better name: we could use it as an alias for
setdefault and then remove setdefault in Python 3000.
Just my 2 Eurocents,
More information about the Python-list