py2exe error: 2.4.2.4: No such file or directory

Stephen Thorne stephen.thorne at gmail.com
Tue Mar 8 03:21:50 CET 2005


On Mon, 07 Mar 2005 16:20:30 -0600, Larry Bates <lbates at syscononline.com> wrote:
> I had occasion to look back at a project I did over a year ago
> and needed to make one small change.  I use py2exe to package
> it for distribution via Inno Setup.  After making my change
> I tried to run my setup script that worked fine before and
> get the following message:
> 
> F:\SYSCON\WTS\HTMLmenu>python HTMLmenuSetup.py py2exe -w
> running py2exe
> running build
> running build_scripts
> not copying HTMLmenu.py (up-to-date)
> running install_scripts
> not copying build\scripts-2.2\HTMLmenu.py (output up-to-date)
> +----------------------------------------------------
> | Processing script HTMLmenu.py with py2exe-0.3.3
> +----------------------------------------------------
> Searching modules needed to run 'HTMLmenu.py' on path:
> ['F:\\SYSCON\\WTS\\HTMLmenu\\build\\bdist.win32\\winexe\\lib\\Python22\\Lib\\sit
> e-packages', '', 'F:\\Larry\\Python', 'C:\\Python22\\Lib\\site-packages\\Pythonw
> in', 'C:\\Python22\\Lib\\site-packages\\win32', 'C:\\Python22\\Lib\\site-package
> s\\win32\\lib', 'C:\\Python22\\Lib\\site-packages', 'C:\\Python22\\DLLs', 'C:\\P
> ython22\\lib', 'C:\\Python22\\lib\\lib-tk', 'C:\\Python22', 'C:\\Python22\\lib\\
> site-packages\\HTMLgen', 'F:\\Larry\\Python\\Library', 'C:\\Python22\\lib\\site-
> packages\\PIL', 'C:\\Python22\\lib\\site-packages\\dynwin', 'C:\\Python22\\lib\\
> site-packages\\npstruct', 'C:\\Python22\\lib\\site-packages\\wxPython']
> error: 2.4.2.4: No such file or directory
> 
> The only thing that I can think of is that perhaps I've upgraded my
> wxWindows version.  I checked and 2.4.2.4 is the version, but I don't
> know why py2exe is looking for such a directory.
> 
> Anybody out there have a clue?

it could have something to do ./site-packages/wx.pth

Stephen



More information about the Python-list mailing list