site-packages versus site-python

msoulier msoulier at gmail.com
Sun Mar 6 06:16:02 CET 2005


> Well, broadly, the reason is that it allows version-specific code to
be
> included in libraries.

I've actually found this to be a bit of a pain. I build packages
against say, python2.2, and if you upgrade python to 2.3 the package
breaks. The code works fine so saying it requires python >= 2.2 should
be valid, but the version-specific path prevents that. 

Mike




More information about the Python-list mailing list