mxDateTime on Mac: Fatal Python Error

M.-A. Lemburg mal at egenix.com
Mon Mar 7 23:51:20 CET 2005


contact at alanlittle.org wrote:
> I'm trying to get mxDateTime working on a Mac so that I can use pyscopg
> and cx_Oracle. The Egenix base package builds and installs quite
> happily, but then when I try to import it I get
> 
> 
>>>import mx.DateTime
> 
> Fatal Python error: Interpreter not initialized (version mismatch?)
> Abort
> 
> ... any ideas?

Messages like these are usually the result of a version mismatch
between the Python interpreter and the .so file of the extensions.

Make sure you build the package using the same Python interpreter
you will later use it with.

> Environment:
> 
> OS X 10.3.8
> sys.version: '2.3 (#1, Sep 13 2003, 00:49:11) \n[GCC 3.3 20030304
> (Apple Computer, Inc. build 1495)]'
> egenix-mx-base-2.0.6

Hmm, this might also be some weird Mac OS issue. While we currently
don't support Macs directly, we do welcome suggestions to make them
work on your favorite platform.

Thanks,
-- 
Marc-Andre Lemburg
eGenix.com

Professional Python Services directly from the Source  (#1, Mar 07 2005)
 >>> Python/Zope Consulting and Support ...        http://www.egenix.com/
 >>> mxODBC.Zope.Database.Adapter ...             http://zope.egenix.com/
 >>> mxODBC, mxDateTime, mxTextTools ...        http://python.egenix.com/
________________________________________________________________________

::: Try mxODBC.Zope.DA for Windows,Linux,Solaris,FreeBSD for free ! ::::



More information about the Python-list mailing list