Mod_python installation: apache Warning

Andrea Fiore a.flow at tiscali.it
Wed Mar 16 12:00:02 CET 2005


Hello,
i have compiled mod_python 2.7.10 on a Linux box with Apache 1.3.31,
but after i restarted the web server, i had a strange warning that i
did non understand....

**
bash-2.05b# apachectl configtest
[Wed Mar 16 11:50:26 2005] [warn] Loaded DSO
/usr/libexec/apache/mod_python.so uses plain Apache 1.3 API, this
module might crash under EAPI! (please recompile it with -DEAPI)
Syntax OK
**

What is EAPI? what is DEAPI?
How can i recompile it with DEAPI? (./configure -with-DEAPI doesn't
work! ;-)


Thank you in advance,
Andrea



More information about the Python-list mailing list